You have to login first in order to be able to post messages.
Click here to login or register if you are a new user.

Canon 5D MKII users

hello people

When using my Canon 5D MK2 without my mounted flash for landscapes and just general outdoor shots all the whites seem to blown out when reviewing the images on the screen.

I shoot RAW and slightly under exposed so I can fix in post but do any other 5D users have an explanation
Canon 5D MKII 50mm f1.8 28mm 70mm f2.8 60mm f2.8 macro
Posted: 09/25/2013, 10:41:32 AM
Personally I don't have this problem with the same camera... Is it the case for any light metering setting? I usually use the partial metering. Trying different meterings might solve the problem, besides bracketing of course. I found this online on this topic:

Btw. I see you use the 60mm f2.8 macro... Any other way to use it with the 5Dmk2 then with extention tubes?
Posted: 09/26/2013, 02:55:11 AM
thanks for the reply

iv tried different metering modes but still the same results. I will post an example on Flickr with a link when I get a chance.

And as for the 60mm I just use it on my 550D. I may sell it and put the money towards the 100mm though
Canon 5D MKII 50mm f1.8 28mm 70mm f2.8 60mm f2.8 macro
Posted: 09/26/2013, 03:23:35 AM
Is your screen calibrated? My 5DMKII gives great results, I only shoot in RAW and on manual so I complete control of my speed, aperture and ISO. I rarely have blown highlights so something somewhere is going wrong for you.
28-300, Canon L 24-70, 50mm prime f/1.4, 2 x Canon 580EX II Flash uni...
Posted: 09/26/2013, 14:38:39 PM